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ShowGIF is a GIF (Graphics Interchange Format) file display program that runs under 
Microsoft Windows 3.0.  It is designed to be easy to use, and to take very little system
memory.  ANY system that can run Windows 3.0 can use ShowGIF to display ANY size 
GIF file, however a 256 color Windows display driver, such as Super VGA, is needed 
to display 256 color GIF files in full color.

Features:
* Fast!  The GIF file decoder is written in assembly language, and is one of the 

fastest GIF file readers available.  If you have the memory, ShowGIF can read the 
image into a memory buffer before displaying it, which improves speed even 
more.

* Takes little memory!  Displays ANY size GIF image on ANY system that can run 
Windows 3.0 (a 256 color display driver is highly recommended).  Does not 
require system memory (RAM) to store the GIF file image.  The window may be 
scrolled horizontally and vertically to view different portions of the image.

* Can automatically display GIF images with the correct aspect ratio (so they don't 
appear stretched on one direction).

* Can scale the image so that it fits entirely inside the ShowGIF window (while 
maintaining the correct aspect ratio).

* Allows multiple GIF files to be viewed on the same screen by invoking multiple 
instances of ShowGIF.  Since ShowGIF takes so little memory, many windows can 
be opened at the same time.

* Can use the entire window to display the image (i.e.  turn off the window caption, 
menu, and scroll bars).  This allows the available screen surface area to be used 
most effectively (even when viewing multiple images).

* Can make use of the maximum color palette available to Windows applications, 
by "stealing" system palette entries.

* Can copy a section of the image to the clipboard.

* Can read GIF 87a and GIF 89a files (not all features are implemented -- see note).

In order to take as little memory as possible, ShowGIF has the ability to refresh the 
display directly from the disk file, rather than reading the file into memory first.  This 
allows virtually any size GIF file to be displayed, regardless of available memory.  The 
GIF file reader code has been optimized for maximum speed.  It has been optimized 
for use on a 12 MHz PC/AT compatible computer with 1 MB of RAM.

Note:  ShowGIF is designed to display GIF files that contain a single image.  If a GIF 
file contains more than one image, only the first image is displayed.  The window is 
sized and displayed according to the dimensions of the first image in the file.



Installing ShowGIF
Windows must be installed with a 256 color display driver (Super VGA or better) to 
display 256 color GIF files correctly.  ShowGIF will work with any display, but 256 color
images won't look good on less than a 256 color display.

ShowGIF may be invoked from Program Manager or File Manager.  To install ShowGIF 
under Program Manager, simply copy SHOWGIF.EXE to your Windows directory (or 
any directory on your hard disk).  Select "New..." from the Program Manager "File" 
menu, and select "Program Item" from the dialog box.  Then enter "ShowGIF" for the 
description, and "SHOWGIF.EXE" (include the path if SHOWGIF.EXE is not in the 
Windows directory) for the command line.

To install ShowGIF under File Manager, simply copy SHOWGIF.EXE to your Windows 
directory (or any directory on your hard disk).  Then invoke the Windows 3.0 File 
Manager and select a .GIF file from any directory.  From the "File" menu, select 
"Associate" and enter "SHOWGIF.EXE" (include the path if SHOWGIF.EXE is not in the 
Windows directory) in the edit box.  You are now ready to view any GIF file.

See the section under "Command Line Options" for additional command line options 
that may be included when installing ShowGIF.

Using ShowGIF
To view a GIF file from Program Manager, you must first invoke ShowGIF by clicking 
on the ShowGIF icon.  ShowGIF will open with a blank (white) window.  Select 
"Open..." from the ShowGIF "File" menu.  A standard Windows-style Open File box will
be displayed.  Just select the appropriate directory and GIF file to display, and click on
the OK button.

Viewing a GIF file from File Manager is even easier.  Simply double click on any file 
with a .GIF extension.  ShowGIF will be automatically invoked, and the file will be 
displayed immediately.

Once ShowGIF is open, a different file can be viewed at any time by using the 
"Open..." command in the "File" menu.  The ShowGIF window may be moved, sized, 
and scrolled as needed.  To close the window and terminate ShowGIF, select "Exit" 
from the "File" menu.

The File Menu
Items in the "File" menu allow operations to be performed on files.

New

Clears the currently displayed image from the screen and from memory.

Open...



Opens a new image file for display by ShowGIF.  A standard Windows-style Open File 
box will be displayed.  Just select the appropriate directory and GIF file to display, and
click on the OK button.

Exit

Closes the ShowGIF window and terminates the application.

About ShowGIF...

Displays a dialog box containing information about ShowGIF.  This includes the 
ShowGIF version number, copyright message, and information about the currently 
displayed image.  The status information includes the dimensions and number of 
colors in the current image, the status/size of the image and display buffers, and the 
amount of free system memory available.  If an error occurred while attempting to 
load a memory buffer, an error message will be displayed next to the appropriate 
buffer (image or display).

The Edit Menu
Items in the "Edit" menu allow operations to be performed on the Windows clipboard.

Copy

ShowGIF can copy a rectangular area of a GIF image to the clipboard.  The image can
then be pasted into other Windows applications, such as paint programs.  ShowGIF 
includes the color palette in any image copied to the clipboard.  Unfortunately, not all
paint programs (including Windows 3.0 Paintbrush) use the palette when pasting 
images from the clipboard.  The Windows 3.0 Clipboard application does correctly 
display the image with the proper palette, however.

To copy an area, simply move the cursor to one corner of the area to be copied, and 
press the left mouse button (holding it down).  Then drag the mouse the opposite 
corner of the area, and release the mouse button.  A rectangle will indicate the area 
of the image that has been marked.  Select the "Copy" command from the "Edit" 
menu, or press Ctrl+Ins to perform the copy.

The View Menu
Items in the "View" menu affect the way in which the current image is displayed.  
These commands take effect immediately.

Entire Window

The "Entire Window" option removes the caption, menu bar, and scroll bars from the 
window so that the image fills the entire window.  To return the caption, menu bar, 
and scroll bars to the screen, do one of the following:

1.  Click the middle mouse button
2.  Double click the left mouse button
3.  Press the "Esc" key on the keyboard



When this option is enabled, the image can still be scrolled using the keyboard arrow 
keys.  If the window is maximized before this option is enabled, the image will fill the 
entire screen.



Entire Screen

The "Entire Screen" option uses the entire screen to display the image.  When this 
item is selected, the entire screen is cleared to black, and the image is displayed 
using the full display surface.  To restore the Windows desktop and its contents to the
screen, do one of the following:

1.  Click the middle mouse button
2.  Double click the left mouse button
3.  Press the "Esc" key on the keyboard

When this option is enabled, the image can still be scrolled using the keyboard arrow 
keys.

Correct Aspect Ratio

ON: ShowGIF stretches the image so that it appears to have the correct aspect 
ratio (width/height) for the image and your display.  If round objects appear 
oval, or square objects appear rectangular, you should turn this option ON.

OFF: ShowGIF displays the image directly.  Each pixel on the display corresponds 
directly to a pixel in the GIF file image.  If the image pixels or the display 
pixels are not square, the image may look stretched either horizontally or 
vertically.  (Default)

Not all GIF files contain images with square pixels.  With no correction, these files 
look stretched out either vertically or horizontally.  In addition, some display drivers 
(such as EGA) do not have square pixels, and may cause an image with square pixels 
to look distorted.  The "Correct Aspect Ratio" option corrects these incompatibilities 
by adjusting the image so that it looks correct on the current display.

To correct the aspect ratio of an image, ShowGIF always stretches the image (instead 
of compressing it) along one axis (horizontal or vertical) by performing pixel 
replication.  This prevents pixel information from being lost, as would occur if the 
image were compressed.  The corrected image is always the same size or larger 
(along one axis) than the uncorrected image.

Some newer GIF files (GIF version 89a specification) contain pixel aspect ratio 
information, which is used by ShowGIF to display the image correctly.  However, most
older GIF files (GIF version 87a specification) do not contain explicit aspect ratio 
information.  For files without aspect ratio information, ShowGIF makes some 
assumptions about the pixel aspect ratio based on the dimensions of the image, as 
follows:

Image Pixel
Dimensions Intended Display Aspect Ratio
640 x 200 IBM CGA or EGA 5:12
640 x 350 IBM EGA 19:24
320 x 200 IBM EGA or VGA 5:6
640 x 400 IBM VGA 5:6
320 x 400 (special VGA) 5:3
320 x 480 (special VGA) 2:1
all others (unknown) 1:1





Scale to Window Size

ON: Scales the image so that it fits completely within the current window.  Scaling 
will not change the image's displayed aspect ratio (see "Correct Aspect 
Ratio").  Some pixel information may be lost if the image must be compressed
to fit within the window.

OFF: Displays the image full size (without losing any pixel information).  If the 
image does not fit within the current window, scroll bars will be turned on.  
(default)

Full Palette

ON: Allows ShowGIF to configure up to 254 of the system palette colors (on a 
Super VGA display) according to the GIF file palette.  This can improve the 
color display accuracy of some 256 color GIF files.  The "Full Palette" mode 
reserves only two colors -- black and white -- for Windows, and affects the 
colors of other windows and icons.

OFF: Windows reserves the first 20 colors in the palette as "static" system colors.  
These colors can not be changed when a GIF image is displayed, but they can 
be used to display the image.  The remaining 236 colors are set according to 
the GIF file palette.  (default)

This option is available only with display drivers that support color palettes, such as 
Super VGA.

The Options Menu
Items in the "Options" menu effect the way in which ShowGIF operates.

Auto Window Size

ON: Causes ShowGIF to automatically size the window according to the image 
dimensions when a new GIF file is opened.  (default)

OFF: Prevents ShowGIF from resizing the window when a new GIF file is opened.

Use Image Buffer

ON: Loads a copy of the disk file image into memory (called a "device independent
bitmap" or "DIB").  The image is then displayed from memory instead of from 
disk whenever the window is repainted.  This method repaints the image 
faster, but is subject to memory limitations.  Some files (particularly interlaced
images) may be loaded significantly faster when this option is turned ON.  The
amount of memory required by the image buffer is directly proportional to the 
size of the original image (before scaling).  If there is not enough contiguous 
free memory to load the image, the image is displayed directly to the screen, 
just as if this option were turned OFF (see below).

OFF: Does not use an image buffer.  (default)



Note:  This command takes effect immediately on the current image.  When it is 
turned ON, the image is loaded from disk immediately.  When it is turned OFF, the 
memory buffer is freed.



Use Display Buffer

ON: Prepares a copy of the image in memory (called a "device dependant bitmap")
before displaying it to the system display.  An image which is loaded into a 
display buffer is displayed very fast, because it is scaled and formatted for the
system display when loaded, instead of when displayed.  Consequently, the 
amount of memory required by the display buffer is directly proportional to 
the size of the displayed image (after scaling).  If an image buffer is also used,
the display buffer is loaded from the image buffer instead of from the disk file.

OFF: Does not use a display buffer.  (default)

When both image and display buffering are OFF, ShowGIF displays and repaints the 
image directly from the disk file to the screen.  This method requires no system 
memory to store the image, and will work with any size GIF file.  If you are having 
problems with "out of memory" errors, turn all buffering OFF.  This option is 
recommended for systems with 1MB of system memory or less.

The table below summarizes the effects of the buffer options:

Option Settings: Effect on ShowGIF:

Use Use File File Displays
Image Display Read Display During Memory
Buffer Buffer Speed Speed Read Requirements
OFF OFF Slow Slow Yes Very Low
ON OFF Fast Medium No Medium
OFF ON Slow Fast No Medium
ON ON Fast Fast No High

Key Assignments
ShowGIF is best used with a mouse, but like all Windows programs, it can also be 
used with the keyboard.  The following keys are used by ShowGIF, in addition the 
standard Windows keys.

Key Function
Up Arrow Scroll image up one line (8 pixels)
Down Arrow Scroll image down one line (8 pixels)
Left Arrow Scroll image left one column (8 pixels)
Right Arrow Scroll image right one column (8 pixels)
Page Up Scroll image up one page
Page Down Scroll image down one page
Home Scroll image left one page
End Scroll image right one page



Command Line Options
Yes, ShowGIF has command-line options.  Actually, all Windows applications that can 
be invoked from File Manager have a "filename" command line parameter, but 
ShowGIF supports more.  These options should be put directly into the Program Item 
Properties command line (in Program Manager) or the File Association (in File 
Manager).

Syntax:    SHOWGIF [/options ] [filename  | filespec ]

options Can be any combination of the following letters:
C Turn ON "Correct Aspect Ratio" view (default is OFF)
S Turn ON "Scale to Window Size" view (default is OFF)
A Turn OFF "Auto Window Size" option (default is ON)
I Turn ON "Use Image Buffer" option (default is OFF)
D Turn ON "Use Display Buffer" option (default is OFF)

filename Name (with optional drive and path) of file to open immediately upon 
entry to ShowGIF.  This parameter is automatically appended to the end 
of the command line by File Manager.  Must not contain wildcard 
characters.

filespec Initial drive, directory, and file specification (usually "*.GIF") to be 
used by the "Open..." command.  If a drive and/or directory is specified 
as part of "filespec", ShowGIF makes them the current drive/directory 
upon entry to ShowGIF.

Example 1: SHOWGIF /CSID C:\GIF\*.GIF (Program Manager)
Turn ON "Correct Aspect Ratio", "Scale to Window Size", "Use Image 
Buffer" and "Use Display Buffer" options.  Start in directory "C:\GIF" 
with filespec "*.GIF".

Example 2: SHOWGIF /CA (File Manager)
Turn ON "Correct Aspect Ratio" option.  Turn OFF "Auto Window Size" 
option.  File Manager will automatically add "filename" to the end of 
this command line when a .GIF file is selected.

Additional Information
This program is supplied free to the public domain.  There are no guarantees that this
software will work correctly on your system or with your files -- but it probably will.  It 
may not be sold for profit, but any number of free copies may be made for individual 
use, as long as it is distributed with this documentation.

A donation of $15.00 or any amount would be greatly appreciated.  I'm not a big 
company.  I'm just a poor programmer who writes software in his free time.  If you 
send me a donation of $20.00 or more, I'll send you a 5.25" disk containing the next 
version of ShowGIF when it becomes available.  I'll also include my phone number so 
you can call me directly.  If you live outside the United States, please add extra to 
cover the additional postage costs.  Make check payable to "Christopher P. LaRosa".



Some ideas I have for future versions of ShowGIF are:

* Slide show mode
* BMP file support (saving and viewing)
* Task switching during client area updates (only if I can find a fast way to do it)

Please send your donations, questions, comments, or suggestions about ShowGIF, to 
the address below:

Christopher P. LaRosa
178 Letchworth Avenue
Rochester, New York  14626

I can also be contacted through the CompuServe mail system.  My CompuServe user 
ID is 70541,3676.

Trademarks, Service Marks, Copyrights
Graphics Interchange Format is the copyright property of CompuServe Incorporated.  
GIF is a service mark of CompuServe Incorporated.

Microsoft is a registered trademark of Microsoft Corporation.  Windows is a trademark
of Microsoft Corporation.

Version Information
Vers Date Description of Changes
1.00 12/31/90 Initial Release

1.01 01/15/91 a)  Got rid of those pesky unnecessary scroll bars.  
Scroll bars now turn themselves off if the image can fit inside the
window without scroll bars.

b)  Allow images wider that 1024 pixels.  The previous version 
would fail with images wider than 1024 pixels.

c)  Added full keyboard support for scrolling.
d)  Changed line scrolling to always be 8 pixels.
e)  Restructured and optimized the code.

1.02 01/16/91 a)  Added a work-around for a Windows 3.0 bug 
which sometimes caused scroll bars to turn on or off 
inappropriately when a window was resized.

b)  Added code to disable screen refresh while an arrow key is held 
down (auto-repeating).

1.03 02/11/91 a)  Added the ability to invoke ShowGIF with no 
command line arguments, which allows it to be invoked directly 
from Program Manager.

b)  Changed the "Help" menu to the "File" menu, and added new 
"Open..." and "Exit" commands.

c)  Cursor is now changed to an hourglass while the window is 
being repainted.



1.10 03/11/91 a)  Added the "Copy" command in the "Edit" menu, 
to copy part of the image to the clipboard.

b)  Added the "Entire Window" command in the "View" menu, to fill 
the entire window.

c)  Added the "Full Palette" command in the "View" menu, to 
display the full palette.

d)  Optimized the GIF decoder and display algorithms.  Display 
speed for non-interlaced images has been increased by more 
than 40%.

e)  Added the image dimensions display at the right of the main 
menu bar.

f)  Switched to the medium programming model, which divided the 
application into smaller code segments.

1.20 03/27/91 a)  Added the "Auto Window Size" option in the 
"Options" menu, to disable automatic window sizing.

b)  Added the "Direct from Disk" option in the "Options" menu, to 
allow memory buffering.

c)  Added the "Correct Aspect Ratio" option in the "View" menu, to 
enable aspect ratio correction.

1.21 03/28/91 a)  Added the "Scale to Window Size" option in the 
"View" menu, to scale the image.

b)  Added command line options.

1.22 04/07/91 a)  Fixed a bug which could cause an "Unrecoverable
Application Error" when exiting ShowGIF.

b)  Modified the error handler to terminate ShowGIF if an "out of 
memory" error occurs.  This prevents multiple "out of memory" 
errors from locking up ShowGIF.

c)  Renamed the "Direct from Disk" option to "Use Memory Buffer", 
and inverted its meaning.  This option now takes effect 
immediately.

1.23 05/07/91 a)  Added the "Use Display Buffer" option in the "Options" menu.
b)  Renamed the "Use Memory Buffer" option to "Use Image 

Buffer".
c)  Added status information to the About dialog box.
d)  Added the "Entire Screen" command in the "View" menu.
e)  Added the /D command line option, and changed /M  to /I.


